★ wanayoo — archive 1999 https://github.com/nodeftpd/nodeftpd/issues/143Nouvelle recherche | Portail wanayoo
Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FAILED TO UPLOAD WHEN I CONNECT TO FTP SERVER BY PUBLIC IP #143

Open
abdias-alvarado opened this issue Nov 21, 2019 · 7 comments · May be fixed by #149
Open

FAILED TO UPLOAD WHEN I CONNECT TO FTP SERVER BY PUBLIC IP #143

abdias-alvarado opened this issue Nov 21, 2019 · 7 comments · May be fixed by #149

Comments

@abdias-alvarado
Copy link

@abdias-alvarado abdias-alvarado commented Nov 21, 2019

I can upload files from the CyberDuck client using 127.0.0.1 when I'm in running the server locally. I have open the router port and I've let the firewall know the passive ports range which is the same that pasvPortRangeStart and pasvPortRangeEnd.

When I try to connect to the Public IP or to the Local IP Address from another computer, my server receives the request and let me log in, and it shows me the directories and files I have, so this is fine, but when I try to upload a file this tries and tries and it re-login but finally responds with failed to upload file.

That does not happen when I try to upload a file in the same machine I'm running the server.

Server Details:
Windows Server 2012 E

FTPD Server
npm version 6.4.1
node version 10.15.3

Thanks!

@mk-pmb
Copy link
Contributor

@mk-pmb mk-pmb commented Nov 21, 2019

Sounds like a firewall and/or NAT problem. Also just to make sure, please check you use the latest nodeftpd (see #115), and report which version you used.
Also please try active transfer mode as well as passive transfer mode.

@abdias-alvarado
Copy link
Author

@abdias-alvarado abdias-alvarado commented Nov 22, 2019

Thanks for answering!

How can I enable the active transfer or the passive transfer mode?

@mk-pmb
Copy link
Contributor

@mk-pmb mk-pmb commented Nov 23, 2019

Which transfer mode to use, is a decision of the client program. Usually the default is active and they have a checkbox to enable passive mode instead.

@abdias-alvarado
Copy link
Author

@abdias-alvarado abdias-alvarado commented Dec 16, 2019

How can I specify the External Server IP Address for passive mode transfers? There is a way to do that?

@abdias-alvarado
Copy link
Author

@abdias-alvarado abdias-alvarado commented Dec 16, 2019

It's the same issue in FileZilla when you try to connect in the same way!

https://stackoverflow.com/questions/42503260/ftp-server-running-on-port-2000-over-nat-not-working-on-passive-mode

@mk-pmb
Copy link
Contributor

@mk-pmb mk-pmb commented Sep 17, 2020

Sorry for the late reply, Github failed to notify me. For this scenario you need either an FTP-aware NAT, or an option in the FTP server to impersonate a custom IP address rather then the one it considers itself to use. This latter option is currently missing. I consider this a bug and will make a PR for it. Thank you for reporting it!
Meanwhile, would you mind changing the thread title to use mostly lowercase?

mk-pmb added a commit to mk-pmb/nodeftpd that referenced this issue Sep 17, 2020
@mk-pmb mk-pmb linked a pull request that will close this issue Sep 17, 2020
@mk-pmb
Copy link
Contributor

@mk-pmb mk-pmb commented Sep 17, 2020

I drafted it but I cannot currently test it myself. Could you @abdias-alvarado please test if it works for you and solves the NAT problem?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

2 participants
You can’t perform that action at this time.